svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
di_minor_devt(3devinfo)
Device Information Library Functions di_minor_devt(3DEVINFO)
NAME
di_minor_devt, di_minor_name, di_minor_nodetype, di_minor_spectype -
return libdevinfo minor node information
SYNOPSIS
cc [ flag... ] file... -ldevinfo [ library... ]
#include <libdevinfo.h>
dev_t di_minor_devt(di_minor_t minor);
char *di_minor_name(di_minor_t minor);
char *di_minor_nodetype(di_minor_t minor);
int di_minor_spectype(di_minor_t minor);
PARAMETERS
minor A handle to minor data node.
DESCRIPTION
These functions return libdevinfo minor node information.
RETURN VALUES
The di_minor_name() function returns the minor name. See ddi_cre‐
ate_minor_node(9F) for a description of the name parameter.
The di_minor_devt() function returns the dev_t value of the minor node
that is specified by SYS V ABI. See getmajor(9F), getminor(9F), and
ddi_create_minor_node(9F) for more information.
The di_minor_spectype() function returns the spec_type of the file,
either S_IFCHR or S_IFBLK. See ddi_create_minor_node(9F) for a descrip‐
tion of the spec_type parameter.
The di_minor_nodetype() function returns the minor node_type of the
minor node. See ddi_create_minor_node(9F) for a description of the
node_type parameter.
ERRORS
No errors are defined.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelSafe
SEE ALSO
ddi_create_minor_node(9F), attributes(7), getmajor(9F), getminor(9F)
Writing Device Drivers in Oracle Solaris 11.4
Oracle Solaris 11.4 1 Dec 1998 di_minor_devt(3DEVINFO)