device_get_children(9) 맨 페이지 - 윈디하나의 솔라나라

개요

섹션
맨 페이지 이름
검색(S)

device_get_children(9)

DEVICE_GET_CHILDREN(9)   BSD Kernel Developer's Manual  DEVICE_GET_CHILDREN(9)

NAME
     device_get_children — get a list of devices connected to a device

SYNOPSIS
     #include <sys/param.h>
     #include <sys/bus.h>

     int
     device_get_children(device_t dev, device_t **devlistp, int *devcountp);

DESCRIPTION
     Retrieve a list of all device instances currently connected to dev and
     return the list in *devlistp and the count in *devcountp.  The memory
     allocated for the list should be freed using free(*devlistp, M_TEMP).
     devlistp and devcountp are not changed when an error is returned.

RETURN VALUES
     Zero is returned on success, otherwise an appropriate error is returned.

SEE ALSO
     devclass(9), device(9)

AUTHORS
     This manual page was written by Doug Rabson.

BSD                             August 23, 2008                            BSD
맨 페이지 내용의 저작권은 맨 페이지 작성자에게 있습니다.
RSS ATOM XHTML 5 CSS3