device_find_child(9) 맨 페이지 - 윈디하나의 솔라나라

개요

섹션
맨 페이지 이름
검색(S)

device_find_child(9)

DEVICE_FIND_CHILD(9)     BSD Kernel Developer's Manual    DEVICE_FIND_CHILD(9)

NAME
     device_find_child — search for a child of a device

SYNOPSIS
     #include <sys/param.h>
     #include <sys/bus.h>

     device_t
     device_find_child(device_t dev, const char *classname, int unit);

DESCRIPTION
     This function looks for a specific child of dev with the given classname
     and unit.  If unit is -1, it returns the first child of dev with a match‐
     ing classname (that is, the one with the lowest unit).

RETURN VALUES
     If it exists, the child device is returned, otherwise NULL.

SEE ALSO
     device_add_child(9)

AUTHORS
     This manual page was written by Doug Rabson.

BSD                            February 8, 2005                            BSD
맨 페이지 내용의 저작권은 맨 페이지 작성자에게 있습니다.
RSS ATOM XHTML 5 CSS3