device_disable(9) 맨 페이지 - 윈디하나의 솔라나라

개요

섹션
맨 페이지 이름
검색(S)

device_disable(9)

DEVICE_ENABLE(9)         BSD Kernel Developer's Manual        DEVICE_ENABLE(9)

NAME
     device_enable, device_disable, device_is_enabled — manipulate device
     enabled flag

SYNOPSIS
     #include <sys/param.h>
     #include <sys/bus.h>

     void
     device_enable(device_t dev);

     void
     device_disable(device_t dev);

     int
     device_is_enabled(device_t dev);

DESCRIPTION
     Each device has an enabled flag associated with it.  A device is enabled
     by default when it is created but may be disabled (for instance to pre‐
     vent a destructive or time consuming probe attempt).  To disable a
     device, call device_disable(), to re-enable it, call device_enable() and
     to test to see if a device is enabled, call device_is_enabled().

SEE ALSO
     device(9)

AUTHORS
     This manual page was written by Doug Rabson.

BSD                              June 16, 1998                             BSD
맨 페이지 내용의 저작권은 맨 페이지 작성자에게 있습니다.
RSS ATOM XHTML 5 CSS3