ddi_get8(9f) 맨 페이지 - 윈디하나의 솔라나라

개요

섹션
맨 페이지 이름
검색(S)

ddi_get8(9f)

ddi_get8(9F)                   Kernel Functions                   ddi_get8(9F)



NAME
       ddi_get8,   ddi_get16,   ddi_get32,   ddi_get64,   ddi_getb,  ddi_getw,
       ddi_getl, ddi_getll - read data from the mapped memory address,  device
       register or allocated DMA memory address

SYNOPSIS
       #include <sys/ddi.h>
       #include <sys/sunddi.h>

       uint8_t ddi_get8(ddi_acc_handle_t handle, uint8_t *dev_addr);


       uint16_t ddi_get16(ddi_acc_handle_t handle, uint16_t *dev_addr);


       uint32_t ddi_get32(ddi_acc_handle_t handle, uint32_t *dev_addr);


       uint64_t ddi_get64(ddi_acc_handle_t handle, uint64_t *dev_addr);

INTERFACE LEVEL
       Solaris   DDI  specific  (Solaris  DDI).  The  ddi_getb(),  ddi_getl(),
       ddi_getll(), and ddi_getw()  functions  are  obsolete.  The  ddi_get8()
       function   replaces   ddi_getb().  The  ddi_get32()  function  replaces
       ddi_getl().  The  ddi_get64()  function   replaces   ddi_getll().   The
       ddi_get16() function replaces ddi_getw().

PARAMETERS
       handle      The  data  access handle returned from setup calls, such as
                   ddi_regs_map_setup(9F).


       dev_addr    Base device address.


DESCRIPTION
       The ddi_get8(), ddi_get16(),  ddi_get32(),  and  ddi_get64()  functions
       read  8  bits, 16 bits, 32 bits and 64 bits of data, respectively, from
       the device address, dev_addr.


       Each individual datum will automatically be translated  to  maintain  a
       consistent  view  between  the host and the device based on the encoded
       information in the data access  handle.  The  translation  may  involve
       byte-swapping if the host and the device have incompatible endian char‐
       acteristics.


       For certain bus types, you can call these DDI functions  from  a  high-
       interrupt context. These types include ISA and SBus buses. For details,
       see the sysbus(5) and isa(5) man pages. For the PCI bus, you can, under
       certain conditions, call these DDI functions from a high-interrupt con‐
       text. See pci(5).

RETURN VALUES
       These functions return the value read from the mapped address.

CONTEXT
       These functions can be called from user, kernel, or interrupt context.

ATTRIBUTES
       See attributes(7) for descriptions of the following attributes:


       tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE  TYPEAT‐
       TRIBUTE   VALUE   _   Interface   StabilityT{  ddi_getb(),  ddi_getl(),
       ddi_getll(), and  ddi_getw()  are  Obsolete;  ddi_get8(),  ddi_get16(),
       ddi_get32(), ddi_get64() are Committed T}


SEE ALSO
       ddi_put8(9F),       ddi_regs_map_free(9F),      ddi_regs_map_setup(9F),
       ddi_rep_get8(9F), ddi_rep_put8(9F)



Oracle Solaris 11.4               25 Jan 2017                     ddi_get8(9F)
맨 페이지 내용의 저작권은 맨 페이지 작성자에게 있습니다.
RSS ATOM XHTML 5 CSS3