svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
dax_set_log(3dax)
dax_set_log(3DAX) DAX Library Functions dax_set_log(3DAX)
NAME
dax_set_log - set logging options
SYNOPSIS
cc [ flag... ] file... -ldax [ library...]
#include <dax.h>
dax_status_t
dax_set_log(dax_context_t *ctx, uint64_t options);
DESCRIPTION
This function sets options for logging messages in the libdax functions
that use ctx.
The following are the values for the options parameter, and they can be
logically OR'd together:
DAX_LOG_ERROR Print error messages
DAX_LOG_WARN Print warning messages. A warning message does not
necessarily mean that there is an error.
DAX_LOG_ENTRY Print arguments on entry to a libdax function
DAX_LOG_RETURN Print results on return from a libdax function
DAX_LOG_PERF Print performance data and advice
DAX_LOG_VERBOSE Print additional information during execution of a
libdax function
DAX_LOG_ALL Enable all logging options
Sends messages enabled by options to the syslog(3C) log at the
user.debug priority level. Stops sending messages to the file specified
by dax_set_log_file() if it had been called, and stops sending messages
to the callback handler specified by dax_set_log_callback() if it had
been called.
Continues to send messages enabled by DAX_LOG_OPTIONS to the target
defined by the DAX_LOG_OPTIONS and DAX_LOG_FD environment variables at
dax_thread_init() time.
Disables an option if it is not specified either in options or in
DAX_DEBUG_OPTIONS.
Log messages only serve as an aid to debug problems. The format of all
log messages is not defined and can change in future versions.
If the function returns an error, does not change log options.
RETURN VALUES
DAX_SUCCESS Operation completed successfully
DAX_EINVAL Unrecognized flag in the options
DAX_ETHREAD The calling thread did not create ctx
USAGE
The DAX_LOG_ERROR option prints detailed diagnostics for DAX_EINVAL
errors.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Availabilitysystem/library _ Interface StabilityCommit‐
ted
SEE ALSO
libdax(3LIB), dax_set_log_file(3DAX), dax_set_log_callback(3DAX)
Oracle Solaris 11.4 03 Mar 2017 dax_set_log(3DAX)