svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
dax_encode(3dax)
dax_encode(3DAX) DAX Library Functions dax_encode(3DAX)
NAME
dax_encode - zip data for a specified codec
SYNOPSIS
cc [ flag... ] file... -ldax [ library...]
#include <dax.h>
dax_result_t
dax_encode(dax_context_t *ctx, dax_vec_t *src,
void *buf, size_t *buflen, dax_zip_t *codec);
DESCRIPTION
This function zips the data in src by using the specified codec and
writes the code word stream to buf. The buflen parameter specifies the
size of buf in bytes. It returns the number of bytes written to buf in
buflen.
RETURN VALUES
Returns the number of code words written to buf in the dax_result_t
count field and sets the dax_result_t status field to one of the fol‐
lowing values:
DAX_SUCCESS Operation completed successfully
DAX_EINVAL Invalid argument for src
DAX_ETHREAD The calling thread did not create ctx
DAX_EOVERFLOW Output buffer overflow. Returns the required buffer
size in buflen.
DAX_EZIP Some bytes in src->data have no matching symbol in
codec, or the src->data is not compressible. buf may
be modified.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Availabilitysystem/library _ Interface StabilityCommit‐
ted
SEE ALSO
dax_zip(3DAX), dax_zip_create(3DAX), libdax(3LIB)
Oracle Solaris 11.4 03 Mar 2017 dax_encode(3DAX)