svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
cuserid(3c)
Standard C Library Functions cuserid(3C)
NAME
cuserid - get character login name of the user
SYNOPSIS
#include <stdio.h>
char *cuserid(char *s);
DESCRIPTION
The cuserid() function generates a character-string representation of
the login name under which the owner of the current process is logged
in. If s is a null pointer, this representation is generated in an
internal static area whose address is returned. Otherwise, s is assumed
to point to an array of at least L_cuserid characters; the representa‐
tion is left in this array. The constant L_cuserid is defined in the
<stdio.h> header.
In multithreaded applications, the caller must always supply an array s
for the return value.
RETURN VALUES
If the login name cannot be found, cuserid() returns a null pointer. If
s is not a null pointer, the null character '\0' will be placed at
s[0].
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ MT-LevelMT-Safe
SEE ALSO
getlogin(3C), getpwnam(3C), attributes(7)
Oracle Solaris 11.4 30 Dec 1996 cuserid(3C)