svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
curs_termattrs(3curses)
curs_termattrs(3CURSES) Curses Library Functions curs_termattrs(3CURSES)
NAME
curs_termattrs, baudrate, erasechar, has_ic, has_il, killchar, long‐
name, termattrs, termname - curses environment query routines
SYNOPSIS
cc [ flag ... ] file ... -lcurses [ library ... ]
#include <curses.h>
int baudrate(void);
char erasechar(void);
int has_ic(void);
int has_il(void);
char killchar(void);
char *longname(void);
chtype termattrs(void);
char *termname(void);
DESCRIPTION
The baudrate() routine returns the output speed of the terminal. The
number returned is in bits per second, for example 9600, and is an
integer.
With the erasechar() routine, the user's current erase character is
returned.
The has_ic() routine is true if the terminal has insert- and delete-
character capabilities.
The has_il() routine is true if the terminal has insert- and delete-
line capabilities, or can simulate them using scrolling regions. This
might be used to determine if it would be appropriate to turn on physi‐
cal scrolling using scrollok().
With the killchar() routine, the user's current line kill character is
returned.
The longname() routine returns a pointer to a static area containing a
verbose description of the current terminal. The maximum length of a
verbose description is 128 characters. It is defined only after the
call to initscr() or newterm(). The area is overwritten by each call to
newterm() and is not restored by set_term(), so the value should be
saved between calls to newterm() if longname() is going to be used with
multiple terminals.
If a given terminal doesn't support a video attribute that an applica‐
tion program is trying to use, curses may substitute a different video
attribute for it. The termattrs() function returns a logical OR of all
video attributes supported by the terminal. This information is useful
when a curses program needs complete control over the appearance of the
screen.
The termname() routine returns the value of the environment variable
TERM (truncated to 14 characters).
RETURN VALUES
longname() and termname() return NULL on error.
Routines that return an integer return ERR upon failure and an integer
value other than ERR upon successful completion.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ MT-LevelUnsafe
SEE ALSO
curs_initscr(3CURSES), curs_outopts(3CURSES), curses(3CURSES),
attributes(7)
NOTES
The header <curses.h> automatically includes the headers <stdio.h> and
<unctrl.h>.
Note that termattrs() may be a macro.
Oracle Solaris 11.4 31 Dec 1996 curs_termattrs(3CURSES)