svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
curs_scroll(3curses)
curs_scroll(3CURSES) Curses Library Functions curs_scroll(3CURSES)
NAME
curs_scroll, scroll, scrl, wscrl - scroll a curses window
SYNOPSIS
cc [ flag ... ] file ... -lcurses [ library ... ]
#include <curses.h>
int scroll(WINDOW *win);
int scrl(int n);
int wscrl(WINDOW *win, int n);
DESCRIPTION
With the scroll() routine, the window is scrolled up one line. This
involves moving the lines in the window data structure. As an optimiza‐
tion, if the scrolling region of the window is the entire screen, the
physical screen is scrolled at the same time.
With the scrl() and wscrl() routines, for positive n scroll the window
up n lines (line i+n becomes i); otherwise scroll the window down n
lines. This involves moving the lines in the window character image
structure. The current cursor position is not changed.
For these functions to work, scrolling must be enabled via scrollok().
RETURN VALUES
All routines return the integer ERR upon failure and an integer value
other than ERR upon successful completion.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ MT-LevelUnsafe
SEE ALSO
curs_outopts(3CURSES), curses(3CURSES), attributes(7)
NOTES
The header <curses.h> automatically includes the headers <stdio.h> and
<unctrl.h>.
Note that scrl() and scroll() may be macros.
Oracle Solaris 11.4 31 Dec 1996 curs_scroll(3CURSES)