svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
curs_printw(3curses)
curs_printw(3CURSES) Curses Library Functions curs_printw(3CURSES)
NAME
curs_printw, printw, wprintw, mvprintw, mvwprintw, vwprintw - print
formatted output in curses windows
SYNOPSIS
cc [ flag ... ] file ... -lcurses [ library ... ]
#include <curses.h>
int printw(char *fmt, /* arg */ ... );
int wprintw(WINDOW *win, char *fmt, /* arg */ ... );
int mvprintw(int y, int x, char *fmt, /* arg */ ... );
int mvwprintw(WINDOW *win, int y, int x, char *fmt, /* arg */... );
#include <varargs.h>
int vwprintw(WINDOW *win, char *fmt, /* varglist */ ... );
DESCRIPTION
The printw(), wprintw(), mvprintw(), and mvwprintw() routines are anal‐
ogous to printf() (see printf(3C) ). In effect, the string that would
be output by printf() is output instead as though waddstr() were used
on the given window.
The vwprintw() routine is analogous to vprintf() (see vprintf(3C)) and
performs a wprintw() using a variable argument list. The third argument
is a va_list, a pointer to a list of arguments, as defined in
<varargs.h>.
RETURN VALUES
All routines return the integer ERR upon failure and an integer value
other than ERR upon successful completion.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ MT-LevelUnsafe
SEE ALSO
curses(3CURSES), printf(3C), vprintf(3C), attributes(7)
NOTES
The header <curses.h> automatically includes the headers <stdio.h> and
<unctrl.h>.
Oracle Solaris 11.4 31 Dec 1996 curs_printw(3CURSES)