svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
curs_overlay(3curses)
curs_overlay(3CURSES) Curses Library Functions curs_overlay(3CURSES)
NAME
curs_overlay, overlay, overwrite, copywin - overlap and manipulate
overlapped curses windows
SYNOPSIS
cc [ flag ... ] file ... -lcurses [ library ... ]
#include <curses.h>
int overlay(WINDOW *srcwin, WINDOW *dstwin);
int overwrite(WINDOW *srcwin, WINDOW *dstwin);
int copywin(WINDOW *srcwin, WINDOW *dstwin, int sminrow,
int smincol, int dminrow, int dmincol,
int dmaxrow, int dmaxcol, int overlay);
DESCRIPTION
The overlay() and overwrite() routines overlay srcwin on top of dstwin.
scrwin and dstwin are not required to be the same size; only text where
the two windows overlap is copied. The difference is that overlay() is
non-destructive (blanks are not copied) whereas overwrite() is destruc‐
tive.
The copywin() routine provides a finer granularity of control over the
overlay() and overwrite() routines. Like in the prefresh() routine, a
rectangle is specified in the destination window, (dminrow, dmincol)
and (dmaxrow, dmaxcol), and the upper-left-corner coordinates of the
source window, (sminrow, smincol). If the argument overlay is true,
then copying is non-destructive, as in overlay().
RETURN VALUES
Routines that return an integer return ERR upon failure and an integer
value other than ERR upon successful completion.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ MT-LevelUnsafe
SEE ALSO
curs_refresh(3CURSES), curs_pad(3CURSES), curses(3CURSES),
attributes(7)
NOTES
The header <curses.h> automatically includes the headers <stdio.h> and
<unctrl.h>.
Note that overlay() and overwrite may be macros.
Oracle Solaris 11.4 31 Dec 1996 curs_overlay(3CURSES)