svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
curs_inwstr(3curses)
curs_inwstr(3CURSES) Curses Library Functions curs_inwstr(3CURSES)
NAME
curs_inwstr, inwstr, innwstr, winwstr, winnwstr, mvinwstr, mvinnwstr,
mvwinwstr, mvwinnwstr - get a string of wchar_t characters from a
curses window
SYNOPSIS
cc [ flag ... ] file ... -lcurses[library .. ]
#include <curses.h>
int inwstr(wchar_t *wstr);
int innwstr(wchar_t *wstr, int n);
int winwstr(WINDOW *win, wchar_t *wstr);
int winnwstr(WINDOW *win, wchar_t *wstr, int n);
int mvinwstr(int y, int x, wchar_t *wstr);
int mvinnwstr(int y, int x, wchar_t *wstr, int n);
int mvwinwstr(WINDOW *win, int y, int x, wchar_t *wstr);
int mvwinnwstr(WINDOW *win, int y, int x, wchar_t *wstr, int n);
DESCRIPTION
These routines return the string of wchar_t characters in wstr starting
at the current cursor position in the named window and ending at the
right margin of the window. Attributes are stripped from the charac‐
ters. The four functions with n as the last argument return the string
at most n wchar_t characters long.
RETURN VALUES
All routines return the integer ERR upon failure and an integer value
other than ERR upon successful completion.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ MT-LevelUnsafe
SEE ALSO
curses(3CURSES), attributes(7)
NOTES
The header file <curses.h> automatically includes the header files
<stdio.h>, <unctrl.h> and <widec.h>.
Note that all routines except winnwstr() may be macros.
Oracle Solaris 11.4 31 Dec 1996 curs_inwstr(3CURSES)