svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
curs_inwch(3curses)
curs_inwch(3CURSES) Curses Library Functions curs_inwch(3CURSES)
NAME
curs_inwch, inwch, winwch, mvinwch, mvwinwch - get a wchar_t character
and its attributes from a curses window
SYNOPSIS
cc [ flag ... ] file ... -lcurses [ library .. ]
#include <curses.h>
chtype inwch(void);
chtype winwch(WINDOW *win);
chtype mvinwch(int y, int x);
chtype mvwinwch(WINDOW *win, int y, int x);
DESCRIPTION
These routines return the wchar_t character, of type chtype, at the
current position in the named window. If any attributes are set for
that position, their values are OR-ed into the value returned. Con‐
stants defined in <curses.h> can be used with the logical AND (&) oper‐
ator to extract the character or attributes alone.
Attributes
The following bit-masks may be AND-ed with characters returned by win‐
wch().
A_WCHARTEXT Bit-mask to extract character
A_WATTRIBUTES Bit-mask to extract attributes
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ MT-LevelUnsafe
SEE ALSO
curses(3CURSES), attributes(7)
NOTES
The header file <curses.h> automatically includes the header files
<stdio.h>, <unctrl.h> and <widec.h>.
Note that all of these routines may be macros.
None of these routines can use the color attribute in chtype.
Oracle Solaris 11.4 31 Dec 1996 curs_inwch(3CURSES)