svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
curs_instr(3curses)
curs_instr(3CURSES) Curses Library Functions curs_instr(3CURSES)
NAME
curs_instr, instr, innstr, winstr, winnstr, mvinstr, mvinnstr, mvwin‐
str, mvwinnstr - get a string of characters from a curses window
SYNOPSIS
cc [ flag ... ] file ... -lcurses [ library ... ]
#include <curses.h>
int instr(char *str);
int innstr(char *str, int n);
int winstr(WINDOW *win, char *str);
int winnstr(WINDOW *win, char *str, int n);
int mvinstr(int y, int x, char *str);
int mvinnstr(int y, int x, char *str, int n);
int mvwinstr(WINDOW *win, int y, int x, char *str);
int mvwinnstr(WINDOW *win, int y, int x, char *str, int n);
DESCRIPTION
These routines return a string of characters in str, starting at the
current cursor position in the named window and ending at the right
margin of the window. Attributes are stripped from the characters. The
four functions with n as the last argument return the string at most n
characters long.
RETURN VALUES
All routines return the integer ERR upon failure and an integer value
other than ERR upon successful completion.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ MT-LevelUnsafe
SEE ALSO
curses(3CURSES), attributes(7)
NOTES
The header <curses.h> automatically includes the headers <stdio.h> and
<unctrl.h>.
Note that all routines except winnstr() may be macros.
Oracle Solaris 11.4 31 Dec 1996 curs_instr(3CURSES)