svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
curs_insch(3curses)
curs_insch(3CURSES) Curses Library Functions curs_insch(3CURSES)
NAME
curs_insch, insch, winsch, mvinsch, mvwinsch - insert a character
before the character under the cursor in a curses window
SYNOPSIS
cc [ flag ... ] file... -lcurses [ library ... ]
#include <curses.h>
int insch(chtype ch);
int winsch(WINDOW *win, chtype ch);
int mvinsch(int y, int x, chtype ch);
int mvwinsch(WINDOW *win, int y, int x, chtype ch);
DESCRIPTION
With these routines, the character ch is inserted before the character
under the cursor. All characters to the right of the cursor are moved
one space to the right, with the possibility of the rightmost character
on the line being lost. The cursor position does not change (after mov‐
ing to y, x, if specified). (This does not imply use of the hardware
insert character feature.)
RETURN VALUES
All routines return the integer ERR upon failure and an integer value
other than ERR upon successful completion.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ MT-LevelUnsafe
SEE ALSO
curses(3CURSES), attributes(7)
NOTES
The header <curses.h> automatically includes the headers <stdio.h> and
<unctrl.h>.
Note that insch(), mvinsch(), and mvwinsch() may be macros.
Oracle Solaris 11.4 31 Dec 1996 curs_insch(3CURSES)