svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
curs_inchstr(3curses)
curs_inchstr(3CURSES) Curses Library Functions curs_inchstr(3CURSES)
NAME
curs_inchstr, inchstr, inchnstr, winchstr, winchnstr, mvinchstr,
mvinchnstr, mvwinchstr, mvwinchnstr - get a string of characters (and
attributes) from a curses window
SYNOPSIS
cc [ flag ... ] file ... -lcurses [ library ... ]
#include <curses.h>
int inchstr(chtype *chstr);
int inchnstr(chtype *chstr, int n);
int winchstr(WINDOW *win, chtype *chstr);
int winchnstr(WINDOW *win, chtype *chstr, int n);
int mvinchstr(int y, int x, chtype *chstr);
int mvinchnstr(int y, int x, chtype *chstr, int n);
int mvwinchstr(WINDOW *win, int y, int x, chtype *chstr);
int mvwinchnstr(WINDOW *win, int y, int x, chtype *chstr, int n);
DESCRIPTION
With these routines, a string of type chtype, starting at the current
cursor position in the named window and ending at the right margin of
the window, is returned. The four functions with n as the last argu‐
ment, return the string at most n characters long. Constants defined in
<curses.h> can be used with the & (logical AND) operator to extract the
character or the attribute alone from any position in the chstr (see
curs_inch(3CURSES)).
RETURN VALUES
All routines return the integer ERR upon failure and an integer value
other than ERR upon successful completion.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ MT-LevelUnsafe
SEE ALSO
curs_inch(3CURSES), curses(3CURSES), attributes(7)
NOTES
The header <curses.h> automatically includes the headers <stdio.h> and
<unctrl.h>.
Note that all routines except winchnstr() may be macros.
Oracle Solaris 11.4 31 Dec 1996 curs_inchstr(3CURSES)