svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
curs_inch(3curses)
curs_inch(3CURSES) Curses Library Functions curs_inch(3CURSES)
NAME
curs_inch, inch, winch, mvinch, mvwinch - get a character and its
attributes from a curses window
SYNOPSIS
cc [ flag ... ] file ... -lcurses [ library ... ]
#include <curses.h>
chtype inch(void);
chtype winch(WINDOW *win);
chtype mvinch(int y, int x);
chtype mvwinch(WINDOW *win, int y, int x);
DESCRIPTION
With these routines, the character, of type chtype, at the current
position in the named window is returned. If any attributes are set for
that position, their values are OR-ed into the value returned. Con‐
stants defined in <curses.h> can be used with the logical AND (&) oper‐
ator to extract the character or attributes alone.
Attributes
The following bit-masks can be AND-ed with characters returned by
winch().
A_CHARTEXT Bit-mask to extract character
A_ATTRIBUTES Bit-mask to extract attributes
A_COLOR Bit-mask to extract color-pair field information
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ MT-LevelUnsafe
SEE ALSO
curses(3CURSES), attributes(7)
NOTES
The header <curses.h> automatically includes the headers <stdio.h> and
<unctrl.h>.
Note that all of these routines may be macros.
Oracle Solaris 11.4 31 Dec 1996 curs_inch(3CURSES)