svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
curs_getstr(3curses)
curs_getstr(3CURSES) Curses Library Functions curs_getstr(3CURSES)
NAME
curs_getstr, getstr, wgetstr, mvgetstr, mvwgetstr, wgetnstr - get char‐
acter strings from curses terminal keyboard
SYNOPSIS
cc [ flag ... ] file ... -lcurses [ library ... ]
#include <curses.h>
int getstr(char *str);
int wgetstr(WINDOW *win, char *str);
int mvgetstr(int y, int x, char *str);
int mvwgetstr(WINDOW *win, int y, int x, char *str);
int wgetnstr(WINDOW *win, char *str, int n);
DESCRIPTION
The effect of getstr() is as though a series of calls to getch() were
made, until a newline or carriage return is received. The resulting
value is placed in the area pointed to by the character pointer str.
wgetnstr() reads at most n characters, thus preventing a possible over‐
flow of the input buffer. The user's erase and kill characters are
interpreted, as well as any special keys (such as function keys, HOME
key, and CLEAR key.)
RETURN VALUES
All routines return the integer ERR upon failure and an integer value
other than ERR upon successful completion.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ MT-LevelUnsafe
SEE ALSO
curs_getch(3CURSES), curses(3CURSES), attributes(7)
NOTES
The header <curses.h> automatically includes the headers <stdio.h> and
<unctrl.h>.
Note that getstr(), mvgetstr(), and mvwgetstr() may be macros.
Oracle Solaris 11.4 31 Dec 1996 curs_getstr(3CURSES)