svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
curs_deleteln(3curses)
curs_deleteln(3CURSES) Curses Library Functions curs_deleteln(3CURSES)
NAME
curs_deleteln, deleteln, wdeleteln, insdelln, winsdelln, insertln, win‐
sertln - delete and insert lines in a curses window
SYNOPSIS
cc [ flag ... ] file ... -lcurses [ library ... ]
#include <curses.h>
int deleteln(void);
int wdeleteln(WINDOW *win);
int insdelln(int n);
int winsdelln(WINDOW *win, int n);
int insertln(void);
int winsertln(WINDOW *win);
DESCRIPTION
With the deleteln() and wdeleteln() routines, the line under the cursor
in the window is deleted; all lines below the current line are moved up
one line. The bottom line of the window is cleared. The cursor position
does not change. This does not imply use of a hardware delete line fea‐
ture.
With the insdelln() and winsdelln() routines, for positive n, insert n
lines into the specified window above the current line. The n bottom
lines are lost. For negative n, delete n lines (starting with the one
under the cursor), and move the remaining lines up. The bottom n lines
are cleared. The current cursor position remains the same.
With the insertln() and insertln() routines, a blank line is inserted
above the current line and the bottom line is lost. This does not imply
use of a hardware insert line feature.
RETURN VALUES
All routines return the integer ERR upon failure and an integer value
other than ERR upon successful completion.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ MT-LevelUnsafe
SEE ALSO
curses(3CURSES), attributes(7)
NOTES
The header <curses.h> automatically includes the headers <stdio.h> and
<unctrl.h>.
Note that all but winsdelln() may be macros.
Oracle Solaris 11.4 31 Dec 1996 curs_deleteln(3CURSES)