svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
curs_delch(3curses)
curs_delch(3CURSES) Curses Library Functions curs_delch(3CURSES)
NAME
curs_delch, delch, wdelch, mvdelch, mvwdelch - delete character under
cursor in a curses window
SYNOPSIS
cc [ flag ... ] file ... -lcurses [ library ... ]
#include <curses.h>
int delch(void);
int wdelch(WINDOW *win);
int mvdelch(int y, int x);
int mvwdelch(WINDOW *win, int y, int x);
DESCRIPTION
With these routines the character under the cursor in the window is
deleted; all characters to the right of the cursor on the same line are
moved to the left one position and the last character on the line is
filled with a blank. The cursor position does not change (after moving
to y, x, if specified). This does not imply use of the hardware delete
character feature.
RETURN VALUES
All routines return the integer ERR upon failure and an integer value
other than ERR upon successful completion.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ MT-LevelUnsafe
SEE ALSO
curses(3CURSES), attributes(7)
NOTES
The header <curses.h> automatically includes the headers <stdio.h> and
<unctrl.h>.
Note that delch(), mvdelch(), and mvwdelch() may be macros.
Oracle Solaris 11.4 31 Dec 1996 curs_delch(3CURSES)