svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
curs_clear(3curses)
curs_clear(3CURSES) Curses Library Functions curs_clear(3CURSES)
NAME
curs_clear, erase, werase, clear, wclear, clrtobot, wclrtobot, clr‐
toeol, wclrtoeol - clear all or part of a curses window
SYNOPSIS
cc [ flag... ] file ... -lcurses [ library ... ]
#include <curses.h>
int erase(void);
int werase(WINDOW *win);
int clear(void);
int wclear(WINDOW *win);
int clrtobot(void);
int wclrtobot(WINDOW *win);
int clrtoeol(void);
int wclrtoeol(WINDOW *win);
DESCRIPTION
The erase() and werase() routines copy blanks to every position in the
window.
The clear() and wclear() routines are like erase() and werase(), but
they also call clearok() , so that the screen is cleared completely on
the next call to wrefresh() for that window and repainted from scratch.
The clrtobot() and wclrtobot() routines erase all lines below the cur‐
sor in the window. Also, the current line to the right of the cursor,
inclusive, is erased.
The clrtoeol() and wclrtoeol() routines erase the current line to the
right of the cursor, inclusive.
RETURN VALUES
All routines return the integer OK, or a non-negative integer if imme‐
dok() is set. See curs_outopts(3CURSES).
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ MT-LevelUnsafe
SEE ALSO
curs_outopts(3CURSES), curs_refresh(3CURSES), curses(3CURSES),
attributes(7)
NOTES
The header <curses.h> automatically includes the headers <stdio.h> and
<unctrl.h>.
Note that erase(), werase(), clear(), wclear(), clrtobot(), and clr‐
toeol() may be macros.
Oracle Solaris 11.4 31 Dec 1996 curs_clear(3CURSES)