svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
curs_border(3curses)
curs_border(3CURSES) Curses Library Functions curs_border(3CURSES)
NAME
curs_border, border, wborder, box, whline, wvline - create curses bor‐
ders, horizontal and vertical lines
SYNOPSIS
cc [ flag ... ] file ... -lcurses [ library ... ]
#include <curses.h>
int border(chtype ls, chtype rs, chtype ts, chtype bs, chtype tl,
chtype tr, chtype bl,chtype br);
int wborder(WINDOW *win, chtype ls, chtype rs, chtype ts,
chtype bs, chtype tl, chtype tr, chtype bl, chtype br);
int box(WINDOW *win, chtype verch, chtype horch);
int hline(chtype ch, int n);
int whline(WINDOW *win, chtype ch, int n);
int vline(chtype ch, int n);
int wvline(WINDOW *win, chtype ch, int n);
DESCRIPTION
With the border(), wborder(), and box() routines, a border is drawn
around the edges of the window. The arguments and attributes are:
tab(); lw(2.75i) lw(2.75i) lsleft side of the border rsright side of
the border tstop side of the border bsbottom side of the border tltop
left-hand corner trtop right-hand corner blbottom left-hand corner
brbottom right-hand corner
If any of these arguments is zero, then the following default values
(defined in <curses.h>) are used respectively instead: ACS_VLINE,
ACS_VLINE, ACS_HLINE, ACS_HLINE, ACS_ULCORNER, ACS_URCORNER,
ACS_BLCORNER, ACS_BRCORNER.
box(win, verch, horch) is a shorthand for the following call:
wborder(win, verch, verch, horch, horch , 0, 0, 0, 0)
hline() and whline() draw a horizontal (left to right) line using ch
starting at the current cursor position in the window. The current cur‐
sor position is not changed. The line is at most n characters long, or
as many as fit into the window.
vline() and wvline() draw a vertical (top to bottom) line using ch
starting at the current cursor position in the window. The current cur‐
sor position is not changed. The line is at most n characters long, or
as many as fit into the window.
RETURN VALUES
All routines return the integer OK, or a non-negative integer if imme‐
dok() is set. See curs_outopts(3CURSES).
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ MT-LevelUnsafe
SEE ALSO
curs_outopts(3CURSES), curses(3CURSES), attributes(7)
NOTES
The header <curses.h> automatically includes the headers <stdio.h> and
<unctrl.h>.
Note that border() and box() may be macros.
Oracle Solaris 11.4 31 Dec 1996 curs_border(3CURSES)