svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
curs_bkgd(3curses)
curs_bkgd(3CURSES) Curses Library Functions curs_bkgd(3CURSES)
NAME
curs_bkgd, bkgd, bkgdset, wbkgdset, wbkgd - curses window background
manipulation routines
SYNOPSIS
cc [ flag ... ] file ... -lcurses [ library ... ]
#include <curses.h>
int bkgd(chtype ch);
void bkgdset(chtype ch);
void wbkgdset(WINDOW *win, chtype ch);
int wbkgd(WINDOW *win, chtype ch);
DESCRIPTION
The bkgdsets() and wbkgdset() routines manipulate the background of the
named window. Background is a chtype consisting of any combination of
attributes and a character. The attribute part of the background is
combined (ORed) with all non-blank characters that are written into the
window with waddch(). Both the character and attribute parts of the
background are combined with the blank characters. The background
becomes a property of the character and moves with the character
through any scrolling and insert/delete line/character operations. To
the extent possible on a particular terminal, the attribute part of the
background is displayed as the graphic rendition of the character put
on the screen.
The bkgd() and wbkgd() routines combine the new background with every
position in the window. Background is any combination of attributes and
a character. Only the attribute part is used to set the background of
non-blank characters, while both character and attributes are used for
blank positions. To the extent possible on a particular terminal, the
attribute part of the background is displayed as the graphic rendition
of the character put on the screen.
RETURN VALUES
bkgd() and wbkgd() return the integer OK, or a non-negative integer, if
immedok() is set. See curs_outopts(3CURSES).
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ MT-LevelUnsafe
SEE ALSO
curs_addch(3CURSES), curs_outopts(3CURSES), curses(3CURSES),
attributes(7)
NOTES
The header <curses.h> automatically includes the headers <stdio.h> and
<unctrl.h>.
Note that bkgdset() and bkgd() may be macros.
Oracle Solaris 11.4 31 Dec 1996 curs_bkgd(3CURSES)