svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
curs_addwch(3curses)
curs_addwch(3CURSES) Curses Library Functions curs_addwch(3CURSES)
NAME
curs_addwch, addwch, waddwch, mvaddwch, mvwaddwch, echowchar,
wechowchar - add a wchar_t character (with attributes) to a curses win‐
dow and advance cursor
SYNOPSIS
cc [flag]... file... -lcurses [library]...
#include <curses.h>
int addwch(chtype wch);
int waddwch(WINDOW *win, chtype wch);
int mvaddwch(int y, int x, chtype wch);
int mvwaddwch(WINDOW *win, int y, int x, chtype wch);
int echowchar(chtype wch);
int wechowchar(WINDOW *win, chtype wch);
DESCRIPTION
The addwch(),waddwch(),mvaddwch(), and mvwaddwch() routines put the
character wch, holding a wchar_t character, into the window at the cur‐
rent cursor position of the window and advance the position of the win‐
dow cursor. Their function is similar to that of putwchar(3C) in the C
multibyte library. At the right margin, an automatic newline is per‐
formed. At the bottom of the scrolling region, if scrollok is enabled,
the scrolling region is scrolled up one line.
If wch is a tab, newline, or backspace, the cursor is moved appropri‐
ately within the window. A newline also does a clrtoeol(3CURSES) before
moving. Tabs are considered to be at every eighth column. If wch is
another control character, it is drawn in the ^X notation. Calling win‐
wch(3CURSES) after adding a control character does not return the con‐
trol character, but instead returns the representation of the control
character.
Video attributes can be combined with a wchar_t character by OR-ing
them into the parameter. This results in these attributes also being
set. (The intent here is that text, including attributes, can be copied
from one place to another using inwch() and addwch().) See stand‐
out(3CURSES), predefined video attribute constants.
The echowchar() and wechowchar() routines are functionally equivalent
to a call to addwch() followed by a call to refresh(3CURSES), or a call
to waddwch() followed by a call to wrefresh(3CURSES). The knowledge
that only a single character is being output is taken into considera‐
tion and, for non-control characters, a considerable performance gain
might be seen by using these routines instead of their equivalents.
Line Graphics
The following variables may be used to add line drawing characters to
the screen with routines of the addwch() family. When variables are
defined for the terminal, the A_ALTCHARSET bit is turned on. (See
curs_attr(3CURSES)). Otherwise, the default character listed below is
stored in the variable. The names chosen are consistent with the VT100
nomenclature.
tab() box; lw(1.83i) |lw(1.83i) |lw(1.83i) lw(1.83i) |lw(1.83i)
|lw(1.83i) NameDefaultGlyph Description _ ACS_ULCORNER+upper left-hand
corner _ ACS_LLCORNER+lower left-hand corner _ ACS_URCORNER+upper
right-hand corner _ ACS_LRCORNER+lower right-hand corner _
ACS_RTEE+right tee _ ACS_LTEE+left tee _ ACS_BTEE+bottom tee _
ACS_TTEE+top tee _ ACS_HLINE-horizontal line _ ACS_VLINE|vertical line
_ ACS_PLUS+plus _ ACS_S1-scan line 1 _ ACS_S9-scan line 9 _ ACS_DIA‐
MOND+diamond _ ACS_CKBOARD:checker board (stipple) _ ACS_DEGREE'degree
symbol _ ACS_PLMINUS#plus/minus _ ACS_BULLETobullet _ ACS_LARROW<arrow
pointing left _ ACS_RARRROW>arrow pointing right _ ACS_DARROWvarrow
pointing down _ ACS_UARROW^arrow pointing up _ ACS_BOARD#board of
squares _ ACS_LANTERN#lantern symbol _ ACS_BLOCK#solid square block
RETURN VALUE
All routines return the integer ERR upon failure and an integer value
other than ERR upon successful completion, unless otherwise noted in
the preceding routine descriptions.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ MT-LevelUnsafe
SEE ALSO
winwch(3CURSES), refresh(3CURSES), clrtoeol(3CURSES),
curs_attr(3CURSES), curs_inwch(3CURSES), curs_outopts(3CURSES),
curses(3CURSES), standout(3CURSES), wrefresh(3CURSES), putwchar(3C),
attributes(7)
NOTES
The header file <curses.h> automatically includes the header files
<stdio.h>, <unctrl.h> and <widec.h>.
Note that addwch(), mvaddwch(), mvwaddwch(), and echowchar() may be
macros.
None of these routines can use the color attribute in chtype.
Oracle Solaris 11.4 17 Aug 2018 curs_addwch(3CURSES)