svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
curs_addstr(3curses)
curs_addstr(3CURSES) Curses Library Functions curs_addstr(3CURSES)
NAME
curs_addstr, addstr, addnstr, waddstr, waddnstr, mvaddstr, mvaddnstr,
mvwaddstr, mvwaddnstr - add a string of characters to a curses window
and advance cursor
SYNOPSIS
cc [ flag ... ] file ... -lcurses [ library ... ]
#include <curses.h>
int addstr(char *str);
int addnstr(char *str, int n);
int waddstr(WINDOW *win, char *str);
int waddnstr(WINDOW *win, char *str, int n);
int mvaddstr(int y, int x, char *str);
int mvaddnstr(int y, int x, char *str, int n);
int mvwaddstr(WINDOW *win, int y, int x, char *str);
int mvwaddnstr(WINDOW *win, int y, int x, char *str, int n);
DESCRIPTION
All of these routines write all the characters of the null terminated
character string str on the given window. It is similar to calling wad‐
dch() once for each character in the string. The four routines with n
as the last argument write at most n characters. If n is negative, then
the entire string will be added.
RETURN VALUES
All routines return the integer ERR upon failure and an integer value
other than ERR upon successful completion.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ MT-LevelUnsafe
SEE ALSO
curs_addch(3CURSES), curses(3CURSES), attributes(7)
NOTES
The header <curses.h> automatically includes the headers <stdio.h> and
<unctrl.h>.
Note that all routines except waddstr() and waddnstr() may not be
macros.
Oracle Solaris 11.4 31 Dec 1996 curs_addstr(3CURSES)