svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
curs_addchstr(3curses)
curs_addchstr(3CURSES) Curses Library Functions curs_addchstr(3CURSES)
NAME
curs_addchstr, addchstr, addchnstr, waddchstr, waddchnstr, mvaddchstr,
mvaddchnstr, mvwaddchstr, mvwaddchnstr - add string of characters and
attributes to a curses window
SYNOPSIS
cc [ flag ... ] file ... -lcurses [ library ... ]
#include <curses.h>
int addchstr(chtype *chstr);
int addchnstr(chtype *chstr, int n);
int waddchstr(WINDOW *win, chtype *chstr);
int waddchnstr(WINDOW *win, chtype *chstr, int n);
int mvaddchstr(int y, int x, chtype *chstr);
int mvaddchnstr(int y, int x, chtype *chstr, int n);
int mvwaddchstr(WINDOW *win, int y, int x, chtype *chstr);
int mvwaddchnstr(WINDOW *win, int y, int x, chtype *chstr, int n);
DESCRIPTION
All of these routines copy chstr directly into the window image struc‐
ture starting at the current cursor position. The four routines with n
as the last argument copy at most n elements, but no more than will fit
on the line. If n=-1 then the whole string is copied, to the maximum
number that fit on the line.
The position of the window cursor is not advanced. These routines works
faster than waddnstr() (see curs_addstr(3CURSES)) because they merely
copy chstr into the window image structure. On the other hand, care
must be taken when using these functions because they do not perform
any kind of checking (such as for the newline character), they do not
advance the current cursor position, and they truncate the string,
rather then wrapping it around to the next line.
RETURN VALUES
All routines return the integer ERR upon failure and an integer value
other than ERR upon successful completion.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ MT-LevelUnsafe
SEE ALSO
curs_addstr(3CURSES), curses(3CURSES), attributes(7)
NOTES
The header <curses.h> automatically includes the headers <stdio.h> and
<unctrl.h>.
Note that all routines except waddchnstr() and waddchstr() may be
macros.
Oracle Solaris 11.4 31 Dec 1996 curs_addchstr(3CURSES)