svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
cpc_open(3cpc)
CPU Performance Counters Library Functions cpc_open(3CPC)
NAME
cpc_open, cpc_close - initialize the CPU Performance Counter library
SYNOPSIS
cc [ flag... ] file... -lcpc [ library... ]
#include <libcpc.h>
cpc_t *cpc_open(int vers);
int cpc_close(cpc_t *cpc);
DESCRIPTION
The cpc_open() function initializes libcpc(3LIB) and returns an identi‐
fier that must be used as the cpc argument in subsequent libcpc func‐
tion calls. The cpc_open() function takes an interface version as an
argument and returns NULL if that version of the interface is incompat‐
ible with the libcpc implementation present on the system. Usually, the
argument has the value of CPC_VER_CURRENT bound to the application when
it was compiled.
If cpc_open() function is called with CPC_VER_CURRENT, and if the sys‐
tem supports both the CPU performance counter (cpc) and the hardware
sampling (SMPL), cpc_open() function initializes both CPC and SMPL. The
returned identifier can be used as the cpc argument in subsequent
libcpc function calls that require the SMPL functionality. If the sys‐
tem supports only CPC, cpc_open() function initializes only CPC. The
returned identifier can be used as the cpc argument in subsequent
libcpc function calls that do not require the SMPL functionality.
If cpc_open() function is called with CPC_VER_CPC_ONLY, cpc_open()func‐
tion initializes only CPC, whether the system supports SMPL in addition
to CPC or not.
The following macros can be specified to cpc_open() as vers:
CPC_VER_CURRENT If the system supports SMPL in addition to CPC,
cpc_open() initializes both CPC and SMPL. Other‐
wise, cpc_open() initializes only CPC.
CPC_VER_CPC_ONLY cpc_open() initializes only CPC whether the system
support SMPL in addition to CPC or not.
The cpc_close() function releases all resources associated with the cpc
argument. Any bound counters and hardware sampling utilized by the
process are unbound. All entities of type cpc_set_t and cpc_buf_t are
invalidated and destroyed.
RETURN VALUES
If the version requested is supported by the implementation, cpc_open()
returns a cpc_t handle for use in all subsequent libcpc operations. If
the implementation cannot support the version needed by the applica‐
tion, cpc_open() returns NULL, indicating that the application at least
needs to be recompiled to operate correctly on the new platform and
might require further changes.
The cpc_close() function always returns 0.
ERRORS
These functions will fail if:
EINVAL The version requested by the client is incompatible with the
implementation.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelSafe
SEE ALSO
libcpc(3LIB), attributes(7)
Oracle Solaris 11.4 30 Jan 2004 cpc_open(3CPC)