svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
cnd_init(3c)
Standard C Library Functions cnd_init(3C)
NAME
cnd_init, cnd_wait, cnd_timedwait, cnd_signal, cnd_broadcast,
cnd_destroy - C11 condition variable functions
SYNOPSIS
#include <threads.h>
int cnd_init(cnd_t *cond);
int cnd_wait(cnd_t *cond, mtx_t *mtx);
int cnd_timedwait(cnd_t *restrict cond, mtx_t *restrict mtx,
const struct timespec *restrict ts);
int cnd_signal(cnd_t *cond);
int cnd_broadcast(cnd_t *cond);
void cnd_destroy(cnd_t *cond);
DESCRIPTION
The cnd_init(), cnd_wait(), cnd_timedwait(), cnd_signal(), cnd_broad‐
cast(), and cnd_destroy() functions are part of the threads interfaces
as specified in the C11 standard. They are simple wrappers over the
more general pthreads functions. See INCITS/ISO/IEC 9899:2011.
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) C11 ThreadsPOSIX
Threads _ cnd_init()pthread_cond_init() _ cnd_wait()pthread_cond_wait()
_ cnd_timedwait()pthread_cond_timedwait() _ cnd_sig‐
nal()pthread_cond_signal() _ cnd_broadcast()pthread_cond_broadcast() _
cnd_destroy()pthread_cond_destroy()
RETURN VALUES
Upon successful completion, each of the cnd_init(), cnd_wait(),
cnd_timedwait(), cnd_signal(), and cnd_broadcast() functions return
thrd_success. If allocation of memory fails for the newly created con‐
dition, cnd_init() returns thrd_nomem. If the requested resource is not
acquired in the time specified by ts to cnd_timedwait(), cnd_timed‐
wait() returns thrd_timedout. If the request could not otherwise be
honored by any of these functions, thrd_error is returned.
No value is returned by the cnd_destroy() function.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelMT-Safe
SEE ALSO
pthread_cond_broadcast(3C), pthread_cond_destroy(3C),
pthread_cond_init(3C), pthread_cond_signal(3C), pthread_cond_timed‐
wait(3C), pthread_cond_wait(3C), threads.h(3HEAD), attributes(7), con‐
dition(7), mutex(7)
Oracle Solaris 11.4 15 Apr 2019 cnd_init(3C)