svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
closedir(3c)
Standard C Library Functions closedir(3C)
NAME
closedir - close a directory stream
SYNOPSIS
#include <sys/types.h>
#include <dirent.h>
int closedir(DIR *dirp);
DESCRIPTION
The closedir() function closes the directory stream referred to by the
argument dirp. Upon return, the value of dirp may no longer point to an
accessible object of the type DIR. If a file descriptor is used to
implement type DIR, that file descriptor will be closed.
RETURN VALUES
Upon successful completion, closedir() returns 0. Otherwise, −1 is
returned and errno is set to indicate the error.
ERRORS
The closedir() function may fail if:
EBADF The dirp argument does not refer to an open directory stream.
EINTR The closedir() function was interrupted by a signal.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelSafe _ Standard‐
See standards(7).
SEE ALSO
dirfd(3C), opendir(3C), readdir(3C), rewinddir(3C), seekdir(3C),
telldir(3C), attributes(7), standards(7)
Oracle Solaris 11.4 14 May 2018 closedir(3C)