svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
clock(3c)
Standard C Library Functions clock(3C)
NAME
clock - report CPU time used
SYNOPSIS
#include <time.h>
clock_t clock(void);
DESCRIPTION
The clock() function returns the amount of CPU time (in microseconds)
used since the first call to clock() in the calling process. The time
reported is the sum of the user and system times of the calling process
and its terminated child processes for which it has executed the
wait(3C) function, the pclose(3C) function, or the system(3C) function.
RETURN VALUES
Dividing the value returned by clock() by the constant CLOCKS_PER_SEC,
defined in the <time.h> header, will give the time in seconds. If the
process time used is not available or cannot be represented, clock
returns the value (clock_t) −1.
USAGE
The value returned by clock() is defined in microseconds for compati‐
bility with systems that have CPU clocks with much higher resolution.
Because of this, the value returned will wrap around after accumulating
only 2147 seconds of CPU time (about 36 minutes).
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelMT-Safe _ Stan‐
dardSee standards(7).
SEE ALSO
times(2), popen(3C), system(3C), wait(3C), attributes(7), standards(7)
Oracle Solaris 11.4 24 Jul 2002 clock(3C)