svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
call_once(3c)
Standard C Library Functions call_once(3C)
NAME
call_once - initialization function
SYNOPSIS
#include <threads.h>
once_flag flag = ONCE_FLAG_INIT;
void call_once(once_flag *flag, void (*func)(void));
DESCRIPTION
The call_once() function is specified in the C11 standard. It is a sim‐
ple wrapper over the more general pthreads function pthread_once(3C).
See INCITS/ISO/IEC 9899:2011.
The object pointed to by flag must be initialized with the value
ONCE_FLAG_INIT before any call to the call_once() function using that
object and it must not be modified again before the last call to
call_once() using that object.
The constant ONCE_FLAG_INIT is defined in the <threads.h> header.
RETURN VALUES
No value is returned by the call_once() function.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelMT-Safe
SEE ALSO
pthread_once(3C), threads.h(3HEAD), attributes(7)
Oracle Solaris 11.4 11 Jun 2018 call_once(3C)