svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
bioaligned(9f)
bioaligned(9F) Kernel Functions bioaligned(9F)
NAME
bioaligned - check alignment of buffer data
SYNOPSIS
#include <sys/ddi.h>
#include <sys/sunddi.h>
int bioaligned(struct buf *bp, size_t align, int flags);
PARAMETERS
bp Pointer to the buf(9S) structure describing the original I/O
request.
align Power of two alignment being checked.
flags Determines the type of alignment being checked. Flag values
supported are BIOALIGNED_BEGIN (which checks the beginning
address alignment), and BIOALIGNED_END (which checks the end‐
ing address alignment).
INTERFACE LEVEL
Solaris DDI specific (Solaris DDI).
DESCRIPTION
The bioaligned() function checks the alignment of memory associated
with a buffer. It returns 1 if the buffer is aligned and 0 if the buf‐
fer is unaligned.
RETURN VALUES
The bioaligned() function returns 1 if the buffer is aligned and 0 if
the buffer is unaligned.
CONTEXT
The bioaligned() function can be called from any context.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted
SEE ALSO
attributes(7), biodone(9F), bp_mapin(9F), freerbuf(9F), getrbuf(9F),
buf(9S)
Oracle Solaris 11.4 17 Aug 2018 bioaligned(9F)