svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
bind(3c)
Standard C Library Functions bind(3C)
NAME
bind - bind a name to a socket
SYNOPSIS
#include <sys/socket.h>
int bind(int socket, const struct sockaddr *address,
socklen_t address_len);
DESCRIPTION
The bind() function assigns an address to an unnamed socket. Sockets
created with socket(3C) function are initially unnamed. They are iden‐
tified only by their address family.
The function takes the following arguments:
socket Specifies the file descriptor of the socket to be bound.
address Points to a sockaddr structure containing the address to
be bound to the socket. The length and format of the
address depend on the address family of the socket.
address_len Specifies the length of the sockaddr structure pointed
to by the address argument.
The socket in use may require the process to have appropriate privi‐
leges to use the bind() function.
USAGE
An application program can retrieve the assigned socket name with the
getsockname(3C) function.
The special value INADDR_ANY may be specified as the sin_addr field of
the sockaddr_in structure as a wildcard value matching any IPv4 address
on the local machine. For IPv6 sockets, the special value in6addr_any
performs the same function when specified as the sin6_addr field of the
sockaddr_in6 structure. See the inet(4P) and inet6(4P) manual pages for
further details.
RETURN VALUES
Upon successful completion, bind() returns 0. Otherwise, −1 is returned
and errno is set to indicate the error.
ERRORS
The bind() function will fail if:
EADDRINUSE The specified address is already in use.
EADDRNOTAVAIL The specified address is not available from the local
machine.
EAFNOSUPPORT The specified address is not a valid address for the
address family of the specified socket, and the code
was not built with __USE_SUNOS_SOCKETS__ defined as
described in socket.h(3HEAD).
EBADF The socket argument is not a valid file descriptor.
EFAULT The address argument can not be accessed.
EINVAL The socket is already bound to an address, and the
protocol does not support binding to a new address; or
the socket has been shut down.
ENOTSOCK The socket argument does not refer to a socket.
EOPNOTSUPP The socket type of the specified socket does not sup‐
port binding to an address.
If the address family of the socket is AF_UNIX, then bind() will fail
if:
EACCES A component of the path prefix denies search permis‐
sion, or the requested name requires writing in a
directory with a mode that denies write permission.
EDESTADDRREQ The address argument is a null pointer.
EISDIR
EIO An I/O error occurred.
ELOOP Too many symbolic links were encountered in translating
the pathname in address.
ENAMETOOLONG A component of a pathname exceeded NAME_MAX characters,
or an entire pathname exceeded PATH_MAX characters.
ENOENT A component of the pathname does not name an existing
file or the pathname is an empty string.
ENOTDIR A component of the path prefix of the pathname in
address is not a directory.
EROFS The name would reside on a read-only filesystem.
The bind() function may fail if:
EACCES The specified address is protected, and the privilege
{PRIV_NET_PRIVADDR} is not asserted in the effective
set of the current process.
EINVAL The address_len argument is not a valid length for the
address family.
EISCONN The socket is already connected.
ENAMETOOLONG Pathname resolution of a symbolic link produced an
intermediate result whose length exceeds PATH_MAX.
ENOBUFS Insufficient resources were available to complete the
call.
ENOSR There were insufficient STREAMS resources for the oper‐
ation to complete.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelAsync-Signal-
Safe _ StandardSee standards(7).
SEE ALSO
connect(3C), getsockname(3C), listen(3C), remove(3C), socket(3C),
socket.h(3HEAD), inet(4P), inet6(4P), attributes(7), privileges(7),
standards(7)
NOTES
Binding a name in the UNIX domain creates a socket in the file system
that must be deleted by the caller when it is no longer needed by using
remove(3C).
HISTORY
The bind() function has been present since the initial release of
Solaris.
Oracle Solaris 11.4 2 Feb 2021 bind(3C)