svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
basename(3c)
Standard C Library Functions basename(3C)
NAME
basename - return the last element of a path name
SYNOPSIS
#include <libgen.h>
char *basename(char *path);
DESCRIPTION
The basename() function takes the pathname pointed to by path and
returns a pointer to the final component of the pathname, deleting any
trailing '/' characters.
If the string consists entirely of the '/' character, basename()
returns a pointer to the string "/" .
If path is a null pointer or points to an empty string, basename()
returns a pointer to the string "." .
RETURN VALUES
The basename() function returns a pointer to the final component of
path.
USAGE
The basename() function may modify the string pointed to by path, and
may return a pointer to static storage that may then be overwritten by
a subsequent call to basename().
EXAMPLES
Example 1 Examples for Input String and Output String
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) Input StringOutput
String _ "/usr/lib""lib" _ "/usr/""usr" _ "/""/"
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelMT-Safe _ Stan‐
dardSee standards(7).
SEE ALSO
basename(1), dirname(3C), attributes(7), standards(7)
Oracle Solaris 11.4 20 May 2014 basename(3C)