svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
aiowait(3c)
Standard C Library Functions aiowait(3C)
NAME
aiowait - wait for completion of asynchronous I/O operation
SYNOPSIS
#include <sys/asynch.h>
#include <sys/time.h>
aio_result_t *aiowait(const struct timeval *timeout);
DESCRIPTION
The aiowait() function suspends the calling process until one of its
outstanding asynchronous I/O operations completes, providing a synchro‐
nous method of notification.
If timeout is a non-zero pointer, it specifies a maximum interval to
wait for the completion of an asynchronous I/O operation. If timeout is
a zero pointer, aiowait() blocks indefinitely. To effect a poll, the
timeout parameter should be non-zero, pointing to a zero-valued timeval
structure.
The timeval structure is defined in <sys/time.h> and contains the fol‐
lowing members:
long tv_sec; /* seconds */
long tv_usec; /* and microseconds */
RETURN VALUES
Upon successful completion, aiowait() returns a pointer to the result
structure used when the completed asynchronous I/O operation was
requested. Upon failure, aiowait() returns −1 and sets errno to indi‐
cate the error. aiowait() returns 0 if the time limit expires.
ERRORS
The aiowait() function will fail if:
EFAULT The timeout argument points to an address outside the address
space of the requesting process. See NOTES.
EINTR The execution of aiowait() was interrupted by a signal.
EINVAL There are no outstanding asynchronous I/O requests.
EINVAL The tv_secs member of the timeval structure pointed to by
timeout is less than 0 or the tv_usecs member is greater than
the number of seconds in a microsecond.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ MT-LevelSafe
SEE ALSO
aiocancel(3C), aioread(3C), attributes(7)
NOTES
The aiowait() function is the only way to dequeue an asynchronous noti‐
fication. It can be used either inside a SIGIO signal handler or in the
main program. One SIGIO signal can represent several queued events.
Passing an illegal address as timeout will result in setting errno to
EFAULT only if detected by the application process.
Oracle Solaris 11.4 5 Feb 2008 aiowait(3C)