svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
aiocancel(3c)
Standard C Library Functions aiocancel(3C)
NAME
aiocancel - cancel an asynchronous operation
SYNOPSIS
#include <sys/asynch.h>
int aiocancel(aio_result_t *resultp);
DESCRIPTION
aiocancel() cancels the asynchronous operation associated with the
result buffer pointed to by resultp. It may not be possible to immedi‐
ately cancel an operation which is in progress and in this case, aio‐
cancel() will not wait to cancel it.
Upon successful completion, aiocancel() returns 0 and the requested
operation is cancelled. The application will not receive the SIGIO com‐
pletion signal for an asynchronous operation that is successfully can‐
celled.
RETURN VALUES
Upon successful completion, aiocancel() returns 0. Upon failure, aio‐
cancel() returns −1 and sets errno to indicate the error.
ERRORS
aiocancel() will fail if any of the following are true:
EACCES The parameter resultp does not correspond to any outstanding
asynchronous operation, although there is at least one cur‐
rently outstanding.
EFAULT resultp points to an address outside the address space of the
requesting process. See NOTES.
EINVAL There are not any outstanding requests to cancel.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ MT-LevelSafe
SEE ALSO
aioread(3C), aiowait(3C), attributes(7)
NOTES
Passing an illegal address as resultp will result in setting errno to
EFAULT only if it is detected by the application process.
Oracle Solaris 11.4 5 Feb 1997 aiocancel(3C)