VOP_VPTOCNP(9) 맨 페이지 - 윈디하나의 솔라나라

개요

섹션
맨 페이지 이름
검색(S)

VOP_VPTOCNP(9)

VOP_VPTOCNP(9)           BSD Kernel Developer's Manual          VOP_VPTOCNP(9)

NAME
     VOP_VPTOCNP — translate a vnode to its component name

SYNOPSIS
     #include <sys/param.h>
     #include <sys/ucred.h>
     #include <sys/vnode.h>

     int
     VOP_VPTOCNP(struct vnode *vp, struct vnode **dvp, struct ucred *cred,
         char *buf, int *buflen);

DESCRIPTION
     This translates a vnode into its component name, and writes that name to
     the head of the buffer specified by buf.

     vp      The vnode to translate.

     dvp     The vnode of the parent directory of vp.

     cred    The caller credentials.

     buf     The buffer into which to prepend the component name.

     buflen  The remaining size of the buffer.

     The default implementation of VOP_VPTOCNP scans through vp's parent
     directory looking for a dirent with a matching file number.  If vp is not
     a directory, then VOP_VPTOCNP returns ENOENT.

LOCKS
     The vnode should be locked on entry and will still be locked on exit.
     The parent directory vnode will be unlocked on a successful exit.  How‐
     ever, it will have its use count incremented.

RETURN VALUES
     Zero is returned on success, otherwise an error code is returned.

ERRORS
     [ENOMEM]           The buffer was not large enough to hold the vnode's
                        component name.

     [ENOENT]           The vnode was not found on the file system.

SEE ALSO
     vnode(9), VOP_LOOKUP(9)

NOTES
     This interface is a work in progress.

HISTORY
     The function VOP_VPTOCNP appeared in FreeBSD 8.0.

AUTHORS
     This manual page was written by Joe Marcus Clarke.

BSD                              March 8, 2015                             BSD
맨 페이지 내용의 저작권은 맨 페이지 작성자에게 있습니다.
RSS ATOM XHTML 5 CSS3