VOP_IOCTL(9) 맨 페이지 - 윈디하나의 솔라나라

개요

섹션
맨 페이지 이름
검색(S)

VOP_IOCTL(9)

VOP_IOCTL(9)             BSD Kernel Developer's Manual            VOP_IOCTL(9)

NAME
     VOP_IOCTL — device specific control

SYNOPSIS
     #include <sys/param.h>
     #include <sys/vnode.h>

     int
     VOP_IOCTL(struct vnode *vp, u_long command, caddr_t data, int fflag,
         struct ucred *cred, struct thread *td);

DESCRIPTION
     Manipulate a file in device dependent ways.

     Its arguments are:

     vp       The vnode of the file (normally representing a device).

     command  The device specific operation to perform.

     data     Extra data for the specified operation.

     fflag    Some flags ???

     cred     The caller's credentials.

     td       The calling thread.

     Most file systems do not implement this entry point.

LOCKS
     The file should not be locked on entry.

RETURN VALUES
     If successful, zero is returned, otherwise an appropriate error code.

     If the ioctl is not recognized or not handled, ENOTTY should be returned.

SEE ALSO
     vnode(9)

AUTHORS
     This manual page was written by Doug Rabson.

BSD                              July 24, 1996                             BSD
맨 페이지 내용의 저작권은 맨 페이지 작성자에게 있습니다.
RSS ATOM XHTML 5 CSS3