svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
HBA_ResetStatistics(3hbaapi)
Common Fibre Channel HBA Information Library Functions
HBA_GetPortStatistics(3HBAAPI)
NAME
HBA_GetPortStatistics, HBA_GetFC4Statistics, HBA_GetFCPStatistics,
HBA_ResetStatistics - Access Port statistics for a specific HBA port.
SYNOPSIS
cc [ flag... ] file... -lHBAAPI [ library... ]
#include <hbaapi.h>
HBA_STATUS HBA_GetPortStatistics(HBA_HANDLE handle,
HBA_UINT32 portindex, HBA_PORTSTATISTICS *portstatistics);
HBA_STATUS HBA_GetFC4Statistics(HBA_HANDLE handle, HBA_WWN portWWN,
HBA_UINT8 FC4type, HBA_FC4STATISTICS * statistics);
HBA_STATUS HBA_GetFCPStatistics(HBA_HANDLE handle,
const HBA_SCSIID * lunid, HBA_FC4STATISTICS * statistics);
void HBA_ResetStatistics(HBA_HANDLE handle, HBA_UINT32 portindex);
PARAMETERS
handle an open handle returned from HBA_OpenAdapter(3HBAAPI)
portindex the index of a specific port on the HBA as returned
by a call to HBA_GetAdapterAttributes(3HBAAPI). The
maximum value specified should be (HBA_ADAPTERAT‐
TRIBUTES.NumberOfPorts - 1).
portstatistics a pointer to an HBA_PORTSTATISTICS structure. Upon
successful completion, this structure contains the
specified port attributes.
portWWN the Port WWN of the local HBA for which FC-4 statis‐
tics is being returned
FC4type FC-4 protocol Data Structure Type as defined in FC-FS
for which statistics are being requested
statistics a pointer to an HBA_FC4STATISTICS structure where the
specified statistics is being returned
lunid a pointer to an HBA_SCSIID structure specifying the
OS SCSI logical unit where statistics are being
requested
DESCRIPTION
The HBA_GetPortStatistics() function retrieves the statistical informa‐
tion from a given HBA port.
The HBA_GetFC4Statistics() function retrieves the traffic statistics
for a specific FC-4 protocol.
The HBA_GetFCPStatistics() function retrieves the traffic statistics
for a specific FC-4 protocol on the specified OS SCSI logical unit
through that port.
The HBA_ResetStatistics() function sesets the statistical counters to
zero for a given HBA port.
RETURN VALUES
Upon successful completion, HBA_GetPortStatistics() returns HBA_STA‐
TUS_OK. Otherwise, an error value is returned from the underlying VSL
and the values in portstatistics are undefined. If the VSL does not
support a specific statistic, that statistic will have every bit set to
1.
Upon successful completion, HBA_GetFC4Statistics() and HBA_GetFCP‐
Statistics() return HBA_STATUS_OK. Otherwise, an error value is
returned from the underlying VSL and the values in statistics are unde‐
fined. If the VSL does not support a specific statistic, that statistic
will have every bit set to 1.
ERRORS
See libhbaapi(3LIB) for general error status values.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ T{ Standard: FC-HBA Ver‐
sion 4 (API version 2) T} _ MT-LevelSafe _ Standard FC-MI 1.92 (API
version 1)
SEE ALSO
HBA_GetAdapterAttributes(3HBAAPI), HBA_OpenAdapter(3HBAAPI), libh‐
baapi(3LIB), attributes(7)
T11 FC-MI Specification
Oracle Solaris 11.4 1 Sep 2003
HBA_GetPortStatistics(3HBAAPI)