svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
HBA_RefreshInformation(3hbaapi)
Common Fibre Channel HBA Information Library Functions
HBA_RefreshInformation(3HBAAPI)
NAME
HBA_RefreshInformation, HBA_RefreshAdapterConfiguration - refresh
information for a specific HBA
SYNOPSIS
cc [ flag... ] file... -lHBAAPI [ library... ]
#include <hbaapi.h>
void HBA_RefreshInformation(HBA_HANDLE handle);
void HBA_RefreshAdapterConfiguration(void);
PARAMETERS
handle an open handle returned from HBA_OpenAdapter(3HBAAPI)
DESCRIPTION
The HBA_RefreshInformation() function requests that the underlying VSL
reload all information about the given HBA. This function should be
called whenever any function returns HBA_STATUS_ERROR_STALE_DATA, or if
an index that was previously valid returns HBA_STATUS_ERROR_ILLE‐
GAL_INDEX. Because the underlying VSL can reset all indexes relating to
the HBA, all old index values must be discarded by the caller.
The HBA_RefreshAdapterConfiguration() function updates information
about the HBAs present on the system. This function does not change any
of the relationships between the HBA API and adapters that have not
been reconfigured. HBA handles continue to refer to the same HBA even
if it is no longer installed. The HBA name or index assigned by the
library remains assigned to the same HBA even if it has been removed
and reinstalled, as long as the bus position, WWN, and OS device have
not changed. Adapter that have been removed and not replaced cannot
have their HBA handles, HBA names, and HBA indexes reassigned. Calls to
these adapters will generate HBA_STATUS_ERROR_UNAVAILABLE.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ T{ Standard: FC-HBA Ver‐
sion 4 (API version 2) T} _ MT-LevelSafe _ Standard FC-MI 1.92 (API
version 1)
SEE ALSO
HBA_OpenAdapter(3HBAAPI), libhbaapi(3LIB), attributes(7)
T11 FC-MI Specification
Oracle Solaris 11.4 1 Sep 2003
HBA_RefreshInformation(3HBAAPI)