svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
HBA_OpenAdapter(3hbaapi)
Common Fibre Channel HBA Information Library Functions
HBA_OpenAdapter(3HBAAPI)
NAME
HBA_OpenAdapter, HBA_OpenAdapterByWWN, HBA_CloseAdapter - open and
close a specific adapter
SYNOPSIS
cc [ flag... ] file... -lHBAAPI [ library... ]
#include <hbaapi.h>
HBA_HANDLE HBA_OpenAdapter(char *adaptername);
HBA_STATUS HBA_OpenAdapterByWWN(HBA_HANDLE *handle, HBA_WWN wwn);
void HBA_CloseAdapter(HBA_HANDLE handle);
PARAMETERS
adaptername the name of the adapter to open, as returned by
HBA_GetAdapterName(3HBAAPI)
handle
HBA_OpenAdapterByWWN() a pointer to an HBA_HANDLE
HBA_CloseAdapter() the open handle of the adapter
to close, as returned by
HBA_OpenAdapter(3HBAAPI)
wwn the WWN to match the Node WWN or Port WWN of the HBA to
open
DESCRIPTION
The HBA_OpenAdapter() function opens the adapter specified by adapter‐
name and returns a handle used for subsequent operations on the HBA.
The HBA_OpenAdapterByWWN() function opens a handle to the HBA whose
Node or Port WWN matches the wwn argument.
The HBA_CloseAdapter() function closes the open handle.
RETURN VALUES
Upon successful completion, HBA_OpenAdapter() returns a valid HBA_HAN‐
DLE with a numeric value greater than 0. Otherwise, 0 is returned.
The HBA_OpenAdapterByWWN() function returns the following values:
HBA_STATUS_OK
The handle argument contains a valid HBA handle.
HBA_STATUS_ERROR_ILLEGAL_WWN
The wwn argument is not a valid port WWN on the specified HBA.
HBA_STATUS_ERROR_AMBIGUOUS_WWN
The WWN is matched to multiple adapters.
HBA_STATUS_ERROR
An error occurred while opening the adapter.
EXAMPLES
Example 1 Open an adapter.
The following example opens the specified adapter.
handle = HBA_OpenAdapter(adaptername);
if (handle == 0) {
fprintf(stderr, "Unable to open HBA %d with name "
"\"%s\".\n", hbaCount, adaptername);
continue;
}
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ T{ Standard: FC-HBA Ver‐
sion 4 (API version 2) T} _ MT-LevelSafe _ Standard FC-MI 1.92 (API
version 1)
SEE ALSO
HBA_GetAdapterName(3HBAAPI), HBA_OpenAdapter(3HBAAPI), libhbaapi(3LIB),
attributes(7)
T11 FC-MI Specification
Oracle Solaris 11.4 1 Sep 2003 HBA_OpenAdapter(3HBAAPI)