svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
HBA_GetWrapperLibraryAttributes(3hbaapi)
Common Fibre Channel HBA Information Library Functions
HBA_GetWrapperLibraryAttributes(3HBAAPI)
NAME
HBA_GetWrapperLibraryAttributes, HBA_GetVendorLibraryAttributes -
return details about the implementation of the wrapper library and the
vendor specific library
SYNOPSIS
cc [ flag... ] file... -lHBAAPI [ library... ]
#include <hbaapi.h>
HBA_UINT32 HBA_GetWrapperLibraryAttributes(
HBA_LIBRARYATTRIBUTES *attributes);
HBA_UINT32 HBA_GetVendorLibraryAttributes(HBA_UINT32 adapter_index,
HBA_LIBRARYATTRIBUTES *attributes);
PARAMETERS
attributes
HBA_GetWrapperLibraryAttributes()
a pointer to a HBA_LIBRARYATTRIBUTES structure
where the wrapper library information is returned
HBA_GetVendorLibraryAttributes()
a pointer to a HBA_LIBRARYATTRIBUTES structure
where the vendor-specific library information is
returned
adapter_index index of the HBA. The value ust be within the range of
1 and the value returned by HBA_GetNumberO‐
fAdapters(3HBAAPI).
DESCRIPTION
The HBA_GetWrapperLibraryAttributes() function returns details about
the wrapper library.
The HBA_GetVendorLibraryAttributes() function returns details about the
vendor specific library. The vendor-specific library selected is based
on the adapter_index.
RETURN VALUES
The HBA_GetWrapperLibraryAttributes() and HBA_GetVendorLibraryAt‐
tributes() functions return the version of the HBA API specification.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ T{ Standard: FC-HBA Ver‐
sion 4 (API version 2) T} _ MT-LevelSafe _ Standard FC-MI 1.92 (API
version 1)
SEE ALSO
HBA_GetNumberOfAdapters(3HBAAPI), libhbaapi(3LIB), attributes(7)
T11 FC-MI Specification
Oracle Solaris 11.4 27 Nov 2017
HBA_GetWrapperLibraryAttributes(3HBAAPI)