svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
HBA_GetAdapterAttributes(3hbaapi)
Common Fibre Channel HBA Information Library Functions
HBA_GetAdapterAttributes(3HBAAPI)
NAME
HBA_GetAdapterAttributes - retrieve attributes about a specific HBA
SYNOPSIS
cc [ flag... ] file... -lHBAAPI [ library... ]
#include <hbaapi.h>
HBA_STATUS HBA_GetAdapterAttributes(HBA_HANDLE handle,
HBA_ADAPTERATTRIBUTES *hbaattributes);
PARAMETERS
handle an open handle returned from HBA_OpenAdapter(3HBAAPI)
hbaattributes a pointer to an HBA_ADAPTERATTRIBUTES structure. Upon
successful completion, this structure contains the
specified adapter attributes.
DESCRIPTION
The HBA_GetAdapterAttributes() function retrieves the adapter
attributes structure for a given HBA. The caller is responsible for
allocating hbaattributes.
RETURN VALUES
Upon successful completion, HBA_STATUS_OK is returned. Otherwise, an
error value is returned and the values in hbaattributes are undefined.
ERRORS
See libhbaapi(3LIB) for general error status values.
EXAMPLES
Example 1 Return adapter attributes.
The following example returns the adapter attributes into hbaAttrs for
the given handle.
if ((status = HBA_GetAdapterAttributes(handle, &hbaAttrs)) !=
HBA_STATUS_OK) {
fprintf(stderr, "Unable to get adapter attributes for "
"HBA %d with name \"%s\".\n", hbaCount, adaptername);
HBA_CloseAdapter(handle);
continue;
}
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ T{ Standard: FC-HBA Ver‐
sion 4 (API version 2) T} _ MT-LevelSafe _ Standard FC-MI 1.92 (API
version 1)
SEE ALSO
HBA_OpenAdapter(3HBAAPI), libhbaapi(3LIB), attributes(7)
T11 FC-MI Specification
Oracle Solaris 11.4 1 Sep 2003
HBA_GetAdapterAttributes(3HBAAPI)