svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
HBA_FreeLibrary(3hbaapi)
Common Fibre Channel HBA Information Library Functions
HBA_LoadLibrary(3HBAAPI)
NAME
HBA_LoadLibrary, HBA_FreeLibrary - load and free the resources used by
the HBA Common Library
SYNOPSIS
cc [ flag... ] file... -lHBAAPI [ library... ]
#include <hbaapi.h>
HBA_STATUS HBA_LoadLibrary(void);
HBA_STATUS HBA_FreeLibrary(void);
DESCRIPTION
The HBA_LoadLibrary() function loads the Common Library, which in turn
loads each VSL specified in the hba.conf(5) file.
The HBA_FreeLibrary() function releases resources held by the Common
Library and each loaded VSL.
RETURN VALUES
Upon successful completion, HBA_LoadLibrary() and HBA_FreeLibrary()
return HBA_STATUS_OK. Otherwise, an error value is returned.
ERRORS
See libhbaapi(3LIB) for general error status values.
EXAMPLES
Example 1 Load the common library and each VSL.
The following example loads the common library and each VSL.
if ((status = HBA_LoadLibrary()) != HBA_STATUS_OK) {
fprintf(stderr, "HBA_LoadLibrary failed: %d\\n", status);
return;
}
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ T{ Standard: FC-HBA Ver‐
sion 4 (API version 2) T} _ MT-LevelSafe _ Standard FC-MI 1.92 (API
version 1)
SEE ALSO
libhbaapi(3LIB), hba.conf(5), attributes(7)
T11 FC-MI Specification
Oracle Solaris 11.4 1 Sep 2003 HBA_LoadLibrary(3HBAAPI)