svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
FCOE_CreatePort(3fcoe)
FCoE Port Management Library Functions FCOE_CreatePort(3FCOE)
NAME
FCOE_CreatePort - create an FCoE port
SYNOPSIS
cc [ flag... ] file... -lfcoe [ library... ]
#include <libfcoe.h>
FCOE_STATUS FCOE_CreatePort(const FCOE_UINT8 *macLinkName, FCOE_UINT8 portType,
FCOE_PORT_WWN pwwn, FCOE_PORT_WWN nwwn, FCOE_UINT8 promiscuous);
PARAMETERS
macLinkName The name of the MAC link on which to create the FCoE
port.
portType This parameter should always be FCOE_PORTTYPE_INITIATOR
or FCOE_PORTTYPE_TARGET.
pwwn The Port WorldWideName to be used for the FCoE port.
Fill the structure with zeros to let the fcoe driver
generate a valid Port WWN from the MAC address of the
underlying NIC hardware.
nwwn The Node WorldWideName to be used for the FCoE port.
Fill the structure with zeros to let the fcoe driver
generate a valid Node WWN from the MAC address of the
underlying NIC hardware.
promiscuous A non-zero value to enable promiscuous mode on the
underlying NIC hardware. A value of 0 indicates use of
the multiple unicast address feature of the underlying
NIC hardware.
DESCRIPTION
The FCOE_CreatePort() function creates an FCoE port over the specified
MAC link.
RETURN VALUES
The following values are returned:
FCOE_STATUS_ERROR_BUSY
The fcoe driver is busy and cannot complete the operation.
FCOE_STATUS_ERROR_ALREADY
An existing FCoE port was found over the specified MAC link.
FCOE_STATUS_ERROR_OPEN_DEV
Failed to open fcoe device.
FCOE_STATUS_ERROR_WWN_SAME
The specified Port WWN is same as the specified Node WWN.
FCOE_STATUS_ERROR_MAC_LEN
MAC link name exceeds the maximum length.
FCOE_STATUS_ERROR_PWWN_CONFLICTED
The specified Port WWN is already in use.
FCOE_STATUS_ERROR_NWWN_CONFLICTED
The specified Node WWN is already in use.
FCOE_STATUS_ERROR_NEED_JUMBO_FRAME
The MTU size of the specified MAC link needs to be increased to
2500 or above.
FCOE_STATUS_ERROR_OPEN_MAC
Failed to open the specified MAC link.
FCOE_STATUS_ERROR_CREATE_PORT
Failed to create FCoE port on the specified MAC link.
FCOE_STATUS_ERROR_GET_LINKINFO
Failed to get link information by macLinkName.
FCOE_STATUS_OK
The API call was successful.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelSafe
SEE ALSO
libfcoe(3LIB), attributes(7)
Oracle Solaris 11.4 1 Apr 2009 FCOE_CreatePort(3FCOE)