BUF_LOCK(9) 맨 페이지 - 윈디하나의 솔라나라

개요

섹션
맨 페이지 이름
검색(S)

BUF_LOCK(9)

BUF_LOCK(9)              BSD Kernel Developer's Manual             BUF_LOCK(9)

NAME
     BUF_LOCK — locks a buffer

SYNOPSIS
     #include <sys/param.h>
     #include <sys/systm.h>
     #include <sys/uio.h>
     #include <sys/bio.h>
     #include <sys/buf.h>

     int
     BUF_LOCK(struct buf *bp, int locktype);

DESCRIPTION
     The BUF_LOCK() function locks the given buffer.  If the lock is already
     held this call will block until it can acquire the lock unless LK_NOWAIT
     is set.

     Its arguments are:

     bp        The buffer to lock.

     locktype  Flags controlling the type of lock.  See lockmgr(9) for
               details.

RETURN VALUES
     A value of 0 is returned upon success.  See lockmgr(9) for information on
     non-zero return values.

SEE ALSO
     buf(9), BUF_TIMELOCK(9), BUF_UNLOCK(9), lockmgr(9)

AUTHORS
     This manual page was written by Chad David <davidc@acns.ab.ca>.

BSD                              July 9, 2001                              BSD
맨 페이지 내용의 저작권은 맨 페이지 작성자에게 있습니다.
RSS ATOM XHTML 5 CSS3